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Welcome	to	the	Android	Forums	at	AndroidCentral.com.	Android	Concepts	&	Dream	Devices	General	Carrier	Discussion	With	a	single	laser	and	firing	angle,	the	TASER	7	CQ	is	built	exclusively	for	close	quarters,	where	over	85%	of	all	TASER	deployments	occur.Confidence.	Time	savings.	Flexibility.Built	for	close	quartersAccording	to	agency	reports,
over	85%	of	TASER	deployments	occur	within	12	feet	of	a	subject.	The	TASER	7	CQ	is	built	to	support	only	Close	Quarters	Cartridges,	which	allows	its	probes	to	reach	optimal	spread	when	deployed	from	only	3	feet	away	from	the	subject.Save	time	with	dock	and	walkUnlike	past	TASER	Energy	Weapons,	the	TASER	7	CQ	does	not	rely	on	cables	and
manual	firmware	updates.	Now	you	can	assign	devices	in	seconds	with	the	Axon	Device	Manager	application,	and	update	firmware,	upload	logs	and	recharge	simply	by	docking	your	device’s	battery.Enjoy	program	flexibilityWe’ll	work	with	you	to	get	your	TASER	7	CQ	program	up	and	running	to	meet	your	needs	and	budget.	You’ll	have	the	option	to
bundle	cartridges	and	other	accessories	alongside	your	TASER	7	CQ	purchase	to	ensure	budget	certainty	and	equipment	availability.Assign	devices	in	seconds	with	the	Axon	Device	Manager	application,	and	update	firmware,	upload	logs	and	recharge	the	battery	simply	by	docking	it	and	walkingTASER	7	CQ	darts	fly	straighter	and	faster	with	nearly
twice	the	kinetic	energy	for	better	connection	to	the	target,	and	the	body	of	the	dart	breaks	away	to	allow	for	attainment	at	tough	anglesElectricity	is	intentionally	driven	between	all	contacts	to	maximize	the	effectiveness	of	the	probe	deployment	and	to	help	compensate	for	close	probe	spreads	or	clothing	disconnects.	Learn	more	hereCompatible
with	TASER	7	AccessoriesThe	TASER	7	CQ	is	compatible	with	most	TASER	7	consumables	and	accessories,	including	holsters,	batteries,	and	training	targets.	Because	the	TASER	7	CQ	is	built	for	close-range	encounters,	it	does	not	support	TASER	7	Standoff	cartridges.IP53	Ingress	Protection	MIL-STD-810G	Test	Method	510.6	(sand	and	dust),	Method
506.6	(rain)	IEC	60529-	4°	F	to	122°	F	[-20°	C	to	50°	C]85%	Relative,	Non-condensing210	Lumen	Light	Emitting	Diode	(LED)1	year	from	date	of	receiptClose-range	optimized	cartridgesStandoff	cartridgesSimultaneous	two	cartridge	reloadTilt	SelectDock	and	walk	workflowBack-up	shotDual	lasers	Automated	and	multithreaded	Sholl	for	direct
analysis	of	fluorescent	images	and/or	traced	morphologies.	Features	powerful	quantifications	based	on	curve	fitting.	Analyis	of	profiles	obtained	by	other	software	is	also	possible.	Originally	released	as	a	stand-alone	Fiji	plugin,	this	program	is	now	part	of	SNT.	Sholl	Analysis	is	based	on	a	publication.	If	you	use	it	successfully	for	your	research	please
be	so	kind	as	to	cite	our	work!	The	manuscript	is	accompanied	by	a	Supplementary	Note	that	presents	the	software	in	further	detail.	Introduction	Skeletonized	hippocampal	CA1	cell	(juvenile	mouse)	in	which	apical	and	basal	dendrites	have	been	analyzed	separately	and	color	coded	according	to	their	Sholl	profile.	Warmer	hues	indicate	higher	number
of	Intersections	(N).	Critical	radius	(rc)	and	Mean	value	(Nav)	are	indicated.	The	Sholl	technique1	is	used	to	describe	neuronal	arbors.	This	plugin	can	perform	Sholl	directly	on	2D	and	3D	grayscale	images	of	isolated	neurons.	Its	internal	algorithm	to	collect	data	is	based	upon	how	Sholl	analysis	is	done	by	hand	—	it	creates	a	series	of	concentric
shells	(circles	or	spheres)	around	the	focus	of	a	neuronal	arbor,	and	counts	how	many	times	connected	voxels	defining	the	arbor	intersect	the	sampling	shells.	The	major	advantages	of	this	plugin	over	other	implementations	are:	Installation	After	installing	SNT,	Sholl	commands	can	be	accessed	through	the	Plugins	›	Neuroanatomy	›	Neuroanatomy
Shortcut	Window,	or	the	SNT	icon	in	the	ImageJ	toolbar.	Direct	Analysis	of	Images	In	this	mode	(bitmap	analysis),	the	plugin	requires	a	binary	image	or	a	segmented	grayscale	image	(2D	or	3D)	containing	a	single	neuron.	Segment	the	neuronal	arbor	using	Image	›	Adjust	›	Threshold…	(shortcut:	⇧	Shift	+	T).	When	using	multichannel	images,	you	will
have	to	set	the	its	display	mode	to	Grayscale	using	Image	›	Color	›	Channels	Tool…	(⇧	Shift	+	Z),	because	images	displayed	as	Composites	cannot	be	thresholded.	Define	the	center	of	analysis	using	a	valid	startup	ROI.	Run	Analysis	›	Sholl	›	Sholl	Analysis…,	adjusting	the	default	Parameters	in	the	dialog	prompt.	Press	More	»	Cf.	Segmentation	to
visually	inspect	the	two	thresholded	phases:	arbor	and	background.	Problems?	Read	the	FAQs.	Some	of	the	illustrations	of	this	manual	pertain	to	older	versions	of	the	software.	Most	prompts	have	meanwhile	been	simplified.	However,	descriptions	remain	relevant	to	current	use.	Startup	ROI	The	center	of	analysis	can	be	specified	using	one	of	three
possibilities:	Straight	line:	A	Straight	line	from	the	focus	of	the	arbor	to	its	most	distal	point	using	the	Straight	Line	Tool.	The	advantages	of	using	line	selections	are	twofold:	1)	Center	of	analysis	and	Ending	radius	are	automatically	set,	and	2)	Horizontal/vertical	lines	(created	by	holding	⇧	Shift	while	using	the	Straight	Line	Selection	Tool)	can	be
used	to	restrict	analysis	to	sub-regions	of	the	image.	Single	point:	A	single	point	marking	the	focus	of	the	arbor	using	the	Point	Selection	Tool.	With	single	point	selections,	only	the	center	of	analysis	is	defined.	Thus,	this	option	is	suitable	for	batch	processing	of	images	with	different	dimensions	with	undefined	Ending	radius.	Multi-point	selection:A
Multi-point	selection	(multi-point	counter)	in	which	the	first	point	marks	the	center	of	analysis	while	the	remaining	points	mark	(count)	the	number	of	primary	branches	required	for	the	calculation	of	ramification	indices).	Suitable	for	cases	in	which	inference	from	starting	radius	is	not	effective.	Three	types	of	ROIs	expected	by	the	plugin	when
analyzing	images	directly.	Left:	Line	defining	center	of	analysis	(focal	point),	hemisphere	restriction	and	ending	radius.	Middle:	Single	point	defining	center	of	analysis.	Right:	Multi-point	selection	in	which	the	first	point	defines	the	focal	point	while	the	remaining	points	(2	to	5)	serve	as	counters	for	primary	neurites.	Cf.	Segmentation	Press	More»	Cf.
Segmentation	to	visually	confirm	which	phase	of	the	segmented	image	will	be	sampled.	This	command	highlights	foreground	from	background	pixels	and	is	particularly	useful	when	analyzing	black	and	white	(binary)	images	or	when	using	the	B&W	lookup	table	in	the	Threshold	Widget	(Image	›	Adjust	›	Threshold…	⇧	Shift	+	T).	Cf.	Segmentation
allows	you	to	ensure	that	you	are	measuring	neuronal	processes	and	not	the	interstitial	spaces	between	them.	Here	is	an	example	using	an	axonal	arbor	of	a	Drosophila	olfactory	neuron	from	the	DIADEM	dataset2:	Segmented	image	Cf.	Segmentation	output	Intersections	mask	Top	row:	Image	properly	segmented:	Arbor	is	sampled.	Bottom	row:
Aberrant	segmentation	(inverted	image):	Background	is	sampled.	Note	the	reversal	of	Cf.	Segmentation	output	and	how	the	intersections	mask	no	longer	decorates	the	axonal	processes	but	the	interstitial	spaces	between	them.	The	consequences	of	the	phase	inversion	are	twofold:	1)	the	program	oversamples	(cf.	hue	ramps	on	upper	left	of
Intersections	mask)	and	2)	the	program	detects	artifacts	induced	by	the	edges	of	the	image	(cf.	top-right	and	bottom-right	corners	of	mask	where	intersections	are	sampled	in	the	absence	of	real	axons	at	those	locations).	Also,	note	that	the	initial	black	and	white	image	would	look	the	same	under	an	inverted	lookup	table	(Image	›	Lookup	Tables	›
Invert	LUT).	With	binary	images,	Sholl	Analysis	treats	zero	intensities	as	the	background,	independently	of	the	image	lookup	table	or	the	state	of	the	Black	background	option	in	Process	›	Binary	›	Options….	As	with	any	other	ImageJ	routine	,	confusing	background	with	foreground	pixels	will	lead	to	aberrant	results,	including:	1)	overestimation	of
branches	and	2)	artifacts	at	distances	intersecting	the	boundaries	of	the	image	canvas.	Analysis	of	Traced	Cells	Main	prompt	(v3.6.8)	when	input	is	traced	data	In	this	mode	the	plugin	analyzes	reconstructed	arbors,	which	is	particularly	relevant	for	stainings	that	do	not	allow	single-cell	resolution	or	proper	segmentation.	Traced	cells	are	better
analyzed	through	SNT’s	main	interface,	as	it	offers	more	options	for	defining	the	center	of	analysis,	tagged	branches,	etc.	However,	dedicated	prompts	are	also	available	(Plugins	›	Sh	›	Sholl	Analysis	(Tracings)…)	for	cases	in	which	viewing	traces	is	not	necessary,	or	when	batch	processing	is	needed,	since	such	prompts	are	macro	recordable	and/or
themselves	created	by	scripts.	You	can	use	analyze	reconstructed	data	from	any	software	capable	of	SWC,	not	just	SNT.	Third-party	software	includes	Py3DN,	Neuromantic	,	NeuronStudio	,	neuTube	,	or	Vaa3D	).	In	addition,	L-Measure	,	NLMorphologyConverter	or	Neuron	can	also	be	used	to	convert	several	file	formats	(including	proprietary	formats
from	closed-source	commercial	software	such	as	Neurolucida®,	MicroBrightField,	Inc.)	into	SWC.	Run	Sholl	Analysis	(Tracings)…	and	specify	a	tracing	file	(swc,	eswc	or	traces	extension).	If	needed,	you	can	also	specify	the	image	associated	with	the	reconstruction.	This	will	allow	the	plugin	to	use	the	image’s	metadata	to	determine	spatial	units	and
x,y,z	spacing.	Choose	the	center	of	analysis	using	the	drop	down	menu	in	the	main	prompt	listing	SWC	tags	(axon,	dendrite,	soma,	etc.).	Note	that	if	your	tracings	are	not	tagged	you	can	do	so	in	SNT	Adjust	the	default	Parameters	Problems?	Read	the	FAQs	Analysis	of	Existing	Profiles	Linear	plot	for	CA1	cell	described	above.	Using	the	soma	as
center,	image	was	sampled	twice	using	the	Restrict	analysis	to	hemicircle/hemisphere	option	in	order	to	segregate	apical	from	basal	dendrites.	For	convenience,	distances	for	basal	branches	were	assigned	negative	values.	For	clarity,	the	binary	image	of	the	arbor	was	rotated,	scaled	and	overlaid	(in	green)	over	the	plot	canvas.	Note	that	it	is	also
possible	to	restrict	curve	fitting	to	a	sub-range	of	distances	once	data	is	collected.	Input	data:	Any	tab	or	comma	delimited	text	file	(.csv,	.txt,	.xls,	.ods)	can	be	used.	You	can	drag	&	drop	these	files	into	the	main	ImageJ	window,	import	data	from	the	clipboard,	or	use	data	from	any	other	table	already	opened	by	ImageJ.	Restricting	input	data:	To
restrict	measurements	to	a	range	of	distances	(see	related	example),	select	the	range	of	distances	you	want	analyze.	You	can	click	the	first	row	in	the	range,	and	then	drag	the	mouse	to	the	last	row,	or	by	holding	down	⇧	Shift	while	selecting	the	last	row	in	the	range.	Then,	in	the	prompt,	activate	the	Restrict	analysis	to	selected	rows	only	checkbox.
Calculation	of	Radius	step	size:	Radius	step	size	is	calculated	from	the	difference	between	the	first	two	rows	in	Distance	column.	This	is	mainly	relevant	when	choosing	Annulus/Spherical	shell	as	normalizer.	Parameters	The	majority	of	parameters	is	shared	by	all	the	Analysis	commands	in	theAnalysis	›	Sholl	›	submenu.	However,	some	settings	are
specific	to	the	type	of	data	used	as	input:	A	segmented	image,	a	tracing,	or	a	previously	obtained	profile.	When	analyzing	images,	input	values	take	into	account	the	scale	information	of	the	image	(which	can	be	set	using	the	Analyze	›	Set	Scale…	or	Image	›	Properties…	(⇧	Shift	+	P),	the	type	of	image	(2D	or	3D),	and	its	active	ROI.	Definition	of	Shells
Starting	radius	The	radius	of	the	smallest	sampling	circle/sphere,	i.e.,	the	first	distance	to	be	sampled.	Ending	radius	The	radius	of	the	largest	(last)	sampling	circle/sphere.	It	is	automatically	calculated	if	a	line	ROI	is	used.	Note	that	the	specified	distance	may	not	be	actually	sampled,	if	Radius	step	size	is	not	a	divisor	of	Ending	radius-Starting	radius.
In	this	case,	the	program	will	choose	the	largest	possible	distance	smaller	than	the	specified	value.	You	can	clear	Ending	radius	or	set	it	to	NaN	(“Not	a	Number”)	to	sample	the	entire	image.	This	is	particularly	useful	when	batch	processing	images	with	different	dimensions.	Radius	step	size	The	sampling	interval	between	radii	of	consecutive
sampling	circles/spheres.	This	value	may	be	set	to	zero	for	continuous	(1-voxel	increment)	measurements.	For	stacks	with	anisotropic	voxel	size,	setting	Radius	step	size	to	zero,	sets	the	step	length	to	the	dimension	of	the	matching	isotropic	voxel,	i.e.,	the	cube	root	of	the	product	of	the	voxel	dimensions	(3D	images)	or	the	square	root	of	the	product	of
the	pixel	dimensions	(2D	images).	Restrict	analysis	to	hemicircle/hemisphere	This	option	is	only	available	when	an	orthogonal	radius	has	been	created	(by	holding	⇧	Shift	while	using	the	Straight	Line	Selection	Tool).	It	can	be	used	to	limit	the	analysis	to	sub-compartments	of	the	arbor.	For	horizontal	lines,	this	option	instructs	the	algorithm	to
measure	intersections	at	sites	equidistant	from	the	center	that	have	y-coordinates	above/below	the	drawn	line.	For	vertical	lines,	it	instructs	the	plugin	to	measure	intersections	at	sites	equidistant	from	the	center	that	have	x-coordinates	to	the	left/right	of	the	drawn	line.	Main	prompt	(v3.4.1)	when	input	is	a	segmented	image	Multiple	Samples/Noise
Reduction	Samples	per	radius	(2D	images	only)	Defines	the	number	of	measurements	to	be	performed	at	each	sampling	circumference.	These	measurements	are	then	combined	into	a	single	value	according	to	the	chosen	integration	method.	This	strategy,	a	break	from	previous	approaches,	increases	the	accuracy	of	non-continuos	profiles	by	diluting
out	the	effect	of	processes	extending	tangent	to	the	sampling	circumference.	Visually,	this	option	can	be	imagined	as	the	“thickness”	of	the	sampling	circumference:	e.g.,	for	a	radius	of	100	pixels	and	a	value	of	3	Samples	per	radius,	the	final	number	of	intersections	would	integrate	the	measurements	sampled	at	distances	99,	100	and	101.	Note	that	it
would	not	make	sense	to	increase	the	number	of	samples	beyond	the	length	(in	pixels)	of	Radius	step	size.	For	this	reason,	this	option	is	limited	to	a	draconian	(and	arbitrary)	maximum	of	10	samples.	Samples	integration	(2D	images	only)	The	measure	of	central	tendency	used	to	combine	intersection	counts	when	multiple	Samples	per	radius	are	used.
Options	are	Mean	(the	default),	Median	or	Mode.	Ignore	isolated	(6-connected)	voxels	(3D	images	only)	-	If	checked,	single	isolated	voxels	intersecting	the	surface	of	sampling	spheres	are	not	taken	into	account,	which	may	allow	for	smoother	profiles	on	noisy	image	stacks.	However,	it	should	be	noted	that	connectivity	in	the	stack	volume	may	not
reflect	connectivity	on	the	surface	of	a	digitized	sphere.	Indeed,	in	certain	contexts,	it	is	possible	(though	unlikely)	to	obtain	higher	intersection	counts	when	this	filtering	option	is	active.	Keep	in	mind	that	this	is	just	a	refinement	feature,	and	you	should	not	expect	it	to	mitigate	major	artifacts	derived	from	poor	segmentation.	Descriptors	and	Curve
Fitting	Enclosing	radius	cutoff	The	number	of	intersections	to	be	used	in	the	definition	of	Enclosing	radius.	Number	of	primary	branches	The	number	of	primary	branches	(i.e.,	those	originating	directly	from	cell	soma	when	the	center	of	analysis	is	the	perikaryon)	to	be	used	in	the	calculation	of	Schoenen	ramification	indices.	It	is	automatically
populated	using	multi-point	counts	if	a	multi-point	ROI	is	detected	at	startup.	Set	it	to	zero	(or	NaN)	to	disable	calculations	of	ramification	indices.	Infer	from	starting	radius	If	checked,	the	Number	of	Primary	branches	is	inferred	from	the	count	of	intersections	at	Starting	radius.	Main	prompt	(v3.4.3)	when	input	is	tabular	data	Fit	profile	and	compute
descriptors	If	checked,	data	is	fitted	according	to	the	chosen	method	and	appropriate	metrics	calculated	automatically.	If	unchecked,	only	sampled	data	is	plotted.	Show	fitting	details	-	Choose	this	option	to	have	all	of	the	parameters	of	the	simplex	fitting	printed	to	the	Log	window.	The	coefficient	of	determination	(R2,	a	measure	of	goodness	of	fit)	is
always	stored	in	the	Sholl	Results	table	even	when	this	option	is	not	selected.	Choice	of	Methods	The	type	of	profile(s)	to	be	obtained.	Linear	(profile	without	normalization),	or	normalized	profiles:	Linear-norm,	Semi-log,	or	Log-log.	Polynomial	Specifies	the	degree	of	the	polynomial	to	be	fitted	to	the	Linear	profile3.	While	the	polynomial	of	best
approximation,	or	“best	fit”,	should	be	empirically	determined	for	each	analyzed	cell	type,	it	is	possible	to	ask	the	plugin	to	predict	the	order	of	the	fitting	polynomial	(or	at	least	try)	using	the	choice	Best	fitting	degree.	In	this	case,	the	plugin	will	loop	through	all	the	available	choices	of	polynomials,	perform	each	fit	in	the	background	and	choose	the
one	with	the	highest	coefficient	of	determination.	Most	informative	Select	this	option	when	you	cannot	predict	which	type	of	normalized	profile	best	describes	the	dataset.	If	chosen,	the	plugin	will	use	the	Determination	ratio	to	determine	which	of	Semi-log	or	Log-log	methods	is	more	appropriate.	Linear-norm	is	not	performed.	Best	fitting	degree	and
Most	informative	choices	are	obviously	more	computer-intensive	and	can	be	monitored	by	activating	the	Show	fitting	details	checkbox.	Normalizer	The	property	of	the	sampling	shell	to	be	used	in	the	normalization	of	Linear-norm,	Semi-log,	and	Log-log	profiles.	It	is	described	below.	Output	Options	Create	intersections	mask	If	checked,	a	16/32–bit
maximum	intensity	projection	of	the	analyzed	image	is	generated	in	which	the	measured	arbor	is	painted	according	to	its	Sholl	profile.	The	type	of	data	(Raw,	i.e.,	sampled	or	Fitted)	is	displayed	in	the	image	subtitle	and	can	be	specified	in	Analysis	›	Sholl	›	Metrics	&	Options…	or	using	the	Options…	command	in	the	More»	drop-down	menu.	The
default	Lookup	Table	(LUT)	used	by	the	mask	can	be	changed	using	Image	›	Lookup	Tables.	The	background	color	[gray	level:	0	(black)	to	255	(white)]	can	also	be	set	in	Metrics	&	Options…,	or	at	any	later	point	using	Image	›	Color	›	Edit	Lut…	WYSIWYG	versions	(RGB	images)	of	these	masks	can	be	otained	using	by	pressing	⇧	Shift	+	F	(Image	›
Overlay	›	Flatten)	or	by	running	Analyze	›	Tools	›	Calibration	Bar…	Intersection	points	and	sampling	shells	can	be	retrieved	as	ROIs.	Intersection	points	are	placed	at	edges	of	detected	clusters	of	foreground	pixels,	not	their	center.	Overlay	sampling	shells	and	intersection	points	(2D	images	only)	If	checked,	two	sets	of	ROIS	are	added	to	the	image
overlay:	1)	concentric	shells	matching	sampled	distances	(circular	ROIs	or	composite	ROIs	when	using	hemicircles);	and	2)	Multipoint	ROIs	at	intersection	sites	between	shells	and	clusters	of	foreground	pixels.	Save	results	to	If	checked,	all	the	results	(with	the	exception	of	the	Sholl	Table)	are	saved	to	the	specified	directory.	These	include:	1)	Sholl
plots	(saved	as	PNG	images),	2)	A	table	containing	detailed	data	and	3)	The	Sholl	mask.	Files	are	named	after	the	image	filename	and	analysis	method.	Saving	options	can	be	specified	in	Analysis	›	Sholl	›	Metrics	&	Options…	(Options…	command	in	the	More»	drop-down	menu).	Do	not	display	saved	files	If	checked,	saved	files	are	directly	saved	to	disk
and	are	not	displayed.	Activate	this	option	when	batch	processing	files.	Sholl	Plots	Linear,	Linear-norm,	Semi-log	and	Log-log	profiles	for	the	ddaC	cell	(File	›	Open	Samples	›	ddaC	Neuron),	version	3.0.	Most	of	the	retrieved	metrics	are	automatically	highlighted	by	the	plugin.	Linear	profile:	Mean	value	(horizontal	grid	line)	and	Centroid	(colored
mark).	Logarithmic	profiles:	The	Sholl	regression	coefficient	(also	known	as	Sholl	decay)	can	be	retrieved	by	linear	regression	using	either	the	full	range	of	data	(blue	line)	or	data	within	percentiles	10–90	(red	line).	For	this	particular	cell	type,	the	Semi-log	method	is	more	informative	when	compared	to	the	Log-log	method.	(1)	Linear	N	=	a	+	br	+
cr2	+	dr3	+	er4	+	fr5	+	...	+	xrn	Outputs	a	N	vs	Distance	profile.	Data	is	fitted	to	a	polynomial	function4.	Critical	radius,	Critical	value	and	Mean	value	of	function	are	calculated	(2)	Linear-norm	N/S	=	a	rb	Outputs	a	N/S	vs	Distance	profile.	Points	are	fitted	to	a	power	function.	It	is	an	intermediate	representation	of	the	data	that	can	be	used	to	gauge
the	choice	of	normalizer.	Once	plotted	under	a	logarithmic	scale	the	Linear-norm	curve	is	similar	to	the	Semi-log	profile	(3)	Semi-log	log(N/S)	=	-k	r	+	m	Outputs	a	log(N/S)	vs	Distance	profile.	A	linear	regression	is	fitted	to	the	sampled	data.	The	Sholl	regression	coefficient	(k)	is	calculated	(4)	Log-log	log(N/S)	=	-k	×	log(r)	+	m	Outputs	a	log(N/S)	vs
log(Distance)	profile.	Data	is	also	fitted	to	a	straight	line.	This	is	an	alternative	approach5	of	obtaining	a	relevant	regression	coefficient,	when	the	Semi-log	method	returns	a	poor	fit	N	For	2D	images,	the	Number	of	clusters	of	pixels	(8–connected)	intersecting	the	circumference	of	radius	r	For	3D	images,	the	Number	of	clusters	of	voxels	(26-
connected)	intersecting	the	surface	of	the	sphere	of	radius	r	r	Distance	from	center	of	analysis	(radius	of	Sholl	circle/sphere)	log	Natural	logarithm,	the	logarithm	to	the	base	e	SThe	chosen	property	of	the	sampling	shell	to	be	used	in	the	normalization	of	Linear-norm,	Semi-log,	and	Log-log	profiles.	For	2D	images,	the	Perimeter	of	the	sampling
circumference	(2πr)	or	the	Area	of	the	corresponding	circle	(πr2)	For	3D	images,	the	Surface	of	the	sampling	sphere	(4πr2)	or	its	respective	Volume	(4/3πr3)	A	third	normalization	option	is	also	available	when	performing	non-continuous	sampling:	Annulus/Spherical	shell.	In	this	case,	the	normalization	is	performed	against	the	area	of	the	annulus
formed	between	the	circumferences	at	r	±	Radius	step	size/2	(2D	images),	or	against	the	volume	between	the	two	spheres	at	r	±	Radius	step	size/2	(3D	images).	Metrics	Morphometric	descriptors	and	other	properties	of	the	arbor	are	printed	to	a	dedicated	table	named	Sholl	Results.	Output	is	fully	customizable	using	Analysis	›	Sholl	›	Metrics	&
Options…	or	using	the	Options…	command	in	the	More»	drop-down	menu.	The	first	columns	log	analysis	parameters:	Image	Directory,	filename	and	voxel	unit,	Channel,	Lower	and	Upper	Threshold	levels,	X,Y	(in	pixels)	and	Z	(slice	number)	coordinates	of	center	of	analysis,	Starting	and	Ending	radius,	Radius	step,	Number	of	Samples	per	Radius,	etc.
Other	parameters	are	described	below.	Metrics	based	on	sampled	data	Intersecting	radii	The	number	of	sampling	radii	intersecting	the	arbor	at	least	once.	Sum	of	intersections	(Sum	inters.)	The	sum	of	all	intersections.	Mean	of	intersections	(Mean	inters.)	Sum	inters.	divided	by	Intersecting	radii.	See	also	Mean	value,	FAQ	Median	of	intersections
(Median	Inters.)	The	median	value	of	sampled	intersections.	Skewness	The	skewness	of	the	sampled	data,	an	indication	of	how	symmetrical	the	distribution	is	around	its	mean.	Positive	values	indicate	an	asymmetrical	distribution	with	a	longer	tail	to	the	right.	Negative	values	indicate	data	with	a	longer	tail	to	the	left.	A	popular	rule	of	thumb
considers	that	if	the	skewness	is	greater	than	1.0	(or	less	than	-1.0),	the	distribution	may	be	considered	far	from	symmetrical.	See	also	Skewness	(fitted	data)	Kurtosis	The	kurtosis	of	the	sampled	data,	which	quantifies	whether	the	shape	of	the	distribution	matches	that	of	a	Gaussian	distribution,	assuming	that	a	Gaussian	distribution	has	a	kurtosis	of
0.	A	distribution	more	peaked	than	a	Gaussian	has	a	positive	kurtosis	while	a	negative	value	indicates	a	flatter	distribution.	See	also	Kurtosis	(fitted	data)	Highest	count	of	intersections	(Max	inters.)	The	maximum	value	of	sampled	intersections,	i.e.,	the	maximum	in	a	linear	[N	vs	Distance]	profile,	reflecting	the	highest	number	of	processes/branches
in	the	arbor.	See	also	Critical	value.	Radius	of	highest	count	of	intersections	(Max	inters.	radius)	The	distance	at	which	the	Highest	count	of	intersections	occurred,	reflecting	sites	of	highest	branch	density.	Note	that	if	the	same	maximum	occurs	multiple	times,	only	the	first	distance	is	considered.	See	also	Critical	radius	Schoenen	Ramification	index
(Ramification	index	(sampled))	A	measure	of	ramification4:	the	ratio	between	Max	inters.	and	the	number	of	primary	branches.	It	is	only	calculated	when	primary	branches	is	valid	and	not	zero.	See	also	Ramification	index	(fit)	Centroid	radius	The	abcissa	of	the	centroid	(i.e.,	the	geometric	center	or	barycenter)	of	the	linear	profile.	It	is	highlighted	on
the	N	vs	Distance	plot.	Centroid	value	The	ordinate	of	the	centroid	(i.e.,	the	geometric	center	or	barycenter)	of	the	linear	profile.	It	is	highlighted	on	the	N	vs	Distance	plot.	Enclosing	radius	The	last	(thus,	the	widest)	of	Intersecting	radii	to	be	associated	with	the	number	of	intersections	specified	by	Enclosing	radius	cutoff.	For	a	cutoff	of	1	(the
default)	Enclosing	radius	is	the	widest	of	Intersecting	radii.	It	reflects	the	Feret	length	of	the	arbor.	Metrics	based	on	fitted	data	Determination	ratio	The	ratio	of	the	coefficient	of	determination	for	the	semi-log	method	and	that	for	the	log–log	method5.	If	the	semi-log	method	is	better	relatively	to	the	log–log	method,	the	Determination	ratio	becomes
larger	than	1.	It	is	the	parameter	used	by	the	plugin	to	silently	predict	the	normalization	method	that	is	the	most	informative.	The	prediction	can	be	monitored	by	activating	the	Show	fitting	details	checkbox.	Sholl	regression	coefficient	(Regression	coefficient)	The	slope	(multiplied	by	-1)	of	the	linear	regression	described	in	(3)	and	(4),	i.e.,	k,	a
measure	of	the	rate	of	decay	of	the	number	of	branches	with	distance	from	the	center	of	analysis.	Higher	k	values	reflect	larger	changes	in	the	function	log(N/S).	To	optimize	the	fit,	the	plugin	retrieves	a	second	linear	regression	centered	around	the	median	distance,	excluding	distances	at	the	edges	of	the	profile.	Details	of	this	second	fit	are	also
registered	on	the	Sholl	table	under	dedicated	columns,	e.g.,	Sholl	regression	coefficient	[P10-P90],	when	data	within	the	10th–90th	percentile	is	used.	Regression	intercept	The	y-coordinate	m	described	in	(3)	and	(4).	Regression	R2	(Regression	R^2)	The	coefficient	of	determination	of	the	linear	regression	described	in	(3)	and	(4).	Critical	value	The
local	maximum	of	the	polynomial	fit,	i.e,	N	at	Critical	radius	in	(1).	Abbreviation:	Nm.	See	also	Max	inters.	Critical	radius	The	distance	at	which	Critical	value	occurs.	By	default	(see	Advanced	Usage),	it	is	calculated	with	a	precision	of	1/1000	of	Radius	step	size.	Abbreviation:	rc.	See	also	Max	inters.	radius	Nomenclature:	Previous	authors	have	used
different	terms	to	describe	the	largest	value	taken	by	the	Sholl	profile,	including	Dendrite	maximum.	Since	the	Sholl	technique	is	not	restricted	to	dendritic	arbors	and	can	be	applied	to	any	tree-like	structure	such	as	axonal	arbors,	mammary	ducts	or	blood	vessels	(cf.	List	of	citations),	Here	we	adopt	the	term	Critical	radius,	renaming	Dendrite
maximum	(Nm)	to	Critical	value.	Mean	value	The	mean	value3	of	the	fitted	polynomial	function	(1),	representing	the	average	of	intersections	over	the	whole	area	occupied	by	the	arbor.	Abbreviation	Nav.	On	the	Sholl	plot,	it	is	highlighted	as	the	height	of	the	rectangle	that	has	the	width	of	Enclosing	radius	−	First	intersecting	radius	and	the	same
area	of	the	area	under	the	fitted	curve	on	that	discrete	interval.	It	is	analogous	to	Mean	inters.,	the	arithmetic	mean	of	sampled	intersections	throughout	the	arbor	(cf.	Metrics	based	on	sampled	data).	By	default	(see	Advanced	Usage),	it	is	calculated	with	a	precision	of	1/1000	of	Radius	step	size.	Schoenen	Ramification	index	(Ramification	index	(fit))
Schoenen	Ramification	index	retrieved	from	fitted	profile:	The	ration	between	Critical	value	and	Number	of	primary	branches.	See	also	Ramification	index	(sampled)	Skewness	(Skewness	(fit))	The	skewness	of	the	fitted	polynomial	distribution	between	Starting	radius	and	Ending	radius.	Kurtosis	(Kurtosis	(fit))	The	kurtosis	of	the	fitted	polynomial
distribution	between	Starting	radius	and	Ending	radius.	Polynomial	R2	(Polyn.	R^2)	The	coefficient	of	determination	of	the	polynomial	fit	described	in	(1).	SNT	provides	several	scripts	and	commands	that	faciliate	all	type	of	Sholl-related	analyses.	You’ll	find	them	through	the	Plugins	›	Neuroanatomy	›	Neuroanatomy	Shortcut	Window,	as	well	as	in
Script	Editor’s	Templates	›	Neuroanatomy	menu.	Here	are	some	examples:	Sampled	data	from	the	ddaC	cell	being	fitted	to	polynomials	of	varying	degree	(BAR	script)	Combine	Sholl	Profiles…	aggregates	individual	profiles	into	a	single	plot,	obtaining	the	average	profile	(with	standard	deviation)	of	a	group	of	cells	(v3.6.12	snapshot)	The	Convex	Hull
as	Center	script	exemplifies	how	to	adopt	arbitrary	focal	points,	in	this	case	the	centroid	of	the	neuron’s	convex	hull	(v4.1.2	snapshot)	In	addition,	several	BAR	commands	–	installed	by	subscribing	to	the	BAR	update	site	–	were	designed	to	complement	the	first	release	of	Sholl	Analysis.	While,	some	of	these	tools	have	meanwhile	become	outdate,	some
remain	relevant.	These	include:	Segmentation	tools	Thresholding,	shape-based	masking	and	edge-detection	routines	(full	list)	Find	Peaks	Retrieves	local	maxima	under	several	filtering	options	such	as	peak	amplitude,	peak	height	and	peak	width.	Can	be	used	to	retrieve	secondary	sites	of	branch	density	Fit	Polynomial	Fits	a	polynomial	of	any	degree
to	sampled	data.	Features	an	heuristic	algorithm	for	guessing	a	polynomial	“best	fit”.	Expands	the	built-in	repertoire	of	polynomial	fits	up	to	50th	order	functions.	Create	Boxplot	Allows	direct	comparison	of	metrics	between	groups	or	sets	of	data	(specially	useful	when	tagging	images	with	the	Comment	field	in	Analysis	›	Sholl	›	Metrics	&	Options…)
Interactive	Plotting	Whole-purpose	routine	that	plots	data	from	imported	spreadsheets.	Pre-processing	This	section	discusses	some	aspects	that	should	be	taken	into	account	when	segmenting	neuronal	arbors	to	be	processed	by	Sholl	Analysis.	Since	image	segmentation	(i.e.,	the	partitioning	of	images	into	analyzable	parts)	is	vulnerable	to	noise	and
background	fluorescence,	it	is	not	possible	to	generalize	universal	routines	that	efficiently	binarize	grayscale	images.	This	means	that	any	procedure	that	tries	to	appropriately	describe	the	original	fluorescence	image	with	a	binary	mask	must	be	tailored	to	the	characteristics	of	individual	datasets.	As	mentioned	in	Complementary	Tools,	several
routines	listed	here	as	distributed	through	the	BAR	update	site.	Noise	Noise	can	be	mitigated	through	the	usage	of	processing	filters.	Specially	useful	are	edge-preserving	filters:	Rolling	Ball	or	“Top	hat”	filters,	e.g.,	Process	›	Subtract	Background…	Median	Filtering	(2D/3D),	e.g.,	Process	›	Filters,	Plugins	›	3D	Anisotropic	Diffusion,	Plugins	›	Process	›
Anisotropic	Diffusion	2D	Sobel	Edge	Detection,	e.g.,	Process	›	Find	Edges	Shen-Castan	Edge	Detector	(BAR	plugin),	BAR	›	Segmentation	Frequency	filters,	e.g.,	Process	›	FFT	›	Bandpass	Filter…	Uneven	Illumination	Uneven	illumination	problems,	typically	associated	with	wide	field	microscopy,	do	occur	in	confocal	microscopy	when	signal	from	deep
layers	of	the	tissue	is	not	captured	as	bright	as	with	superficial	layers.	This	signal	attenuation	along	the	Z-axis	will	generate	a	shaded	gradient	across	the	stack	that	histogram-based	segmentation	will	need	to	take	into	account.	While	these	problems	are	better	tackled	during	acquisition	(e.g.,	using	laser	ramping),	it	is	possible	to	mitigate	this	effect
using	histogram-normalization	techniques.	Examples:	Bleach	Correction,	Image	›	Adjust	Attenuation	correction	Segmentation	It	is	possible	to	adopt	more	sophisticated	segmentation	algorithms	when	global	thresholding	methods	do	not	yield	satisfactory	results.	Examples:	Batch	Processing	The	Script	Editor’s	Templates	›	Neuroanatomy	menu	lists
demo	scripts	that	perform	batch	operations.	For	sake	of	completeness,	here	is	a	small	tutorial	on	how	to	write	a	macro	from	the	ground	up:	Tutorial:	Batch	Analysis	of	Images	using	IJM	Languages	Any	macro	must	set	a	center,	or	allow	the	Sholl	Analysis	plugin	to	access	a	ROI	marking	it.	One	could	instruct	ImageJ	to	read	the	coordinates	of	pre-
existing	ROIs	from	a	text	file,	store	a	list	of	line	selections	in	the	ROI	Manager,	or	write	a	morphology-based	routine	that	detects	the	center	of	the	arbor.	However,	marking	the	center	of	analysis	is	probably	something	that	you	will	want	to	do	manually.	Here	is	a	workflow:	Place	all	the	.tif	images	to	be	processed	in	a	single	folder.	Select	the	Point
Selection	Tool	in	the	main	ImageJ	window.	With	3D	images,	make	sure	Set	stack	positions	is	active	in	the	Image	›	Overlay	›	Overlay	Options…	prompt.	Open	the	first	image	and	press	⇧	Shift	+	T	to	activate	the	Threshold	widget	(Image	›	Adjust	›	Threshold…).	Adjust	threshold	levels.	Press	the	Apply	button	of	the	Threshold	widget	to	create	a	binary
image.	Select	the	z-slice	containing	the	center	of	analysis.	Click	over	the	center	with	the	Point	Selection	Tool	and	press	B	(shortcut	for	Image	›	Overlay	›	Add	Selection…).	This	will	add	the	point	ROI	to	the	image	overlay.	Save	the	image	as	.TIFF	by	pressing	S	(File	›	Save	As…	›	Tiff…).	Repeat	the	last	2	steps	until	all	images	are	marked,	using	⇧
Shift	+	O	(shortcut	for	File	›	Open	Next)	to	iterate	through	all	the	images.		When	working	with	ROIs,	it	is	critical	that	you	work	with	.tif	files	because	only	this	format	keeps	track	of	image	overlays.	IJ’s	Process	›	Batch	›	Convert…	command	allows	bulk	conversion	between	image	formats.	Now	that	all	the	images	are	marked,	we	could	use	the	Macro
Recorder	(Plugins	›	Macros	›	Record…)	and	run	Sholl	Analysis	on	one	of	the	images	to	find	out	how	to	call	the	plugin	with	suitable	parameters.	In	this	tutorial,	we	will	use	the	ImageJ	macro	language.	The	single	line	of	code	that	appears	in	the	recorder	window	will	look	something	like	this:	//	Recording	Sholl	Analysis	version	3.4.3	run("Sholl	Analysis...",
"starting=10	ending=400	radius_step=0	infer	fit	linear	polynomial=[8th	degree]	semi-log	normalizer=Volume	create	save	do");	As	you	may	have	noticed,	ImageJ	plugins	are	controlled	by	a	single	lowercase	sentence	in	which	arguments	are	separated	by	a	space.	Input	fields	and	choice	lists	appear	as	keyword=value	pairs,	active	checkboxes	by	a
single	keyword.	Options	that	are	not	needed	can	be	omitted.	This	makes	it	easier	to	edit	code	blocks:	start	=	10;	//	variable	that	controls	starting	radius	end	=	200;	//	variable	that	controls	ending	radius	step	=	2;	//	variable	that	controls	step	size	//	Run	the	plugin	run("Sholl	Analysis...",	"starting="+	start	+"	ending="+	end	+"	radius_step="+	step	+"
infer	linear	save	do");	Now	we	just	need	to	assemble	a	working	macro	to	be	pasted	in	the	Process	›	Batch	›	Macro…	prompt:	//	Get	the	number	of	ROIs	of	the	image	overlay	nROIs	=	Overlay.size;	//	We	cannot	proceed	if	no	ROI	is	available	(safety	check)	if	(nROIs==0)	exit("No	ROI	was	found.	Cannot	proceed.");	//	Select	the	last	ROI	of	the	overlay.
Because	we	have	activated	the	"Set	stack	positions"	option,	//	this	will	automatically	activate	the	Z-slice	in	which	the	ROI	was	created	(3D	images)	Overlay.activateSelection(nROIs-1);	//	We	now	call	the	plugin	as	detailed	by	the	Macro	Recorder.	We'll	set	'Ending	radius'	to	a	non-numeric	//	value	(NaN,	"Not	a	Value")	to	make	sure	the	maximum	length
for	each	individual	image	is	used	run("Sholl	Analysis...",	"starting=10	ending=NaN	radius_step=0	infer	fit	linear	polynomial=[8th	degree]	semi-log	normalizer=Volume	create	save	do");	Of	course	you	can	also	automate	any	preceding	steps.	However,	do	not	forget	to	ensure	that	the	center	of	analysis	will	be	available	when	the	plugin	is	called:	//
Impose	spatial	calibration	run("Properties...",	"unit=um	pixel_width=1.5	pixel_height=1.5	voxel_depth=3.0");	//	Subtract	background	run("Subtract	Background...",	"rolling=50	sliding	stack");	//	Apply	a	favorite	threshold	setAutoThreshold("Huang	dark	stack");	//	>>>>	Make	sure	the	initial	point	selection	remains	available
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